Вт, 23.07.2019, 05:03
Форум інформатиків України
Головна Реєстрація Вхід
Вітаю Вас, Гість · RSS
Вітання на форумі
Незнайомець
Вітаємо на форумі,
Незнайомцю!

 
зареєструйтесь
Перед реєстрацією обов’язково прочитайте:
Оновлення Учасники Пошук
Особисті повідомлення
Видавництво ’’Аспект’’ Видавництво

  • Сторінка 4 з 5
  • «
  • 1
  • 2
  • 3
  • 4
  • 5
  • »
Модератор форуму: Bandalak, Ktara, НІКОЛЯ, volevikt  
Форум інформатиків » РОЗДІЛ VIІІ: ОБМІН ДОСВІДОМ (УРОКИ, ФАКУЛЬТАТИВИ, ПОЗАКЛАСНА РОБОТА) » 8.6 Факультатив з програмування » Мова С++ (поради, запитання....) (Все що стосується програмування на С++)
Мова С++ (поради, запитання....)
fox11 Дата: Пт, 14.12.2018, 18:49 | Повідомлення № 46
Прописаний назавжди
Повідомлень: 333
Нагороди: 4
Рейтинг: 81
Цитата swetikccc ()
А ось шаблончик для української в подарунок
Это лишнее, для этого есть транслит. Privet mir!
Bandalak Дата: Пт, 14.12.2018, 23:03 | Повідомлення № 47
Лідер форуму
Повідомлень: 6192
Нагороди: 44
Рейтинг: 285
Цитата swetikccc ()
Невірне питання.
Яку версію мови С++?

А в кодеБлок можна налаштовувати версії С++?
fox11 Дата: Сб, 15.12.2018, 20:55 | Повідомлення № 48
Прописаний назавжди
Повідомлень: 333
Нагороди: 4
Рейтинг: 81
Цитата Bandalak ()
А в кодеБлок можна
Пользуюсь другой программой https://osdn.net/projects/mingw/releases/

или http://vaultec.mbnet.fi/mingwstudio.php


Відредаговано: fox11 - Сб, 15.12.2018, 21:17
Пилипчук_О_П Дата: Сб, 15.12.2018, 21:02 | Повідомлення № 49
Ветеран спілкування
Повідомлень: 4308
Нагороди: 38
Рейтинг: 406
Цитата Bandalak ()
А в кодеБлок можна налаштовувати версії С++?

Можна приєднати декілька компіляторів і вибирати потрібний.
Bandalak Дата: Нд, 16.12.2018, 17:55 | Повідомлення № 50
Лідер форуму
Повідомлень: 6192
Нагороди: 44
Рейтинг: 285
Цитата fox11 ()
Пользуюсь другой программой https://osdn.net/projects/mingw/releases/

Я за Вас радий. Але ми будемо користуватися виключно тим, що буде на олімпіаді, щоб учні не заплуталися.

Цитата Пилипчук_О_П ()
Можна приєднати декілька компіляторів і вибирати потрібний.

Можна то звичайно можна. Але потрібно відштовхуватися від того, яке середовище буде встановлено на олімпіаді ІІІ етапу, який компілятор буде там приєднаний і яка саме версія компілятора перевірятиме в онлані. Інакше можлива ситуація, що учні звикнуть до деяких фішок найновішої версії, а на олімпіаді її не буде. Відповідно задачі отримають 0 балів.
Пилипчук_О_П Дата: Нд, 16.12.2018, 22:45 | Повідомлення № 51
Ветеран спілкування
Повідомлень: 4308
Нагороди: 38
Рейтинг: 406
Цитата Bandalak ()
потрібно відштовхуватися від того, яке середовище буде встановлено на олімпіаді ІІІ етапу, який компілятор буде там приєднаний

Звичайно. З цим питанням - до організаторів того етапу, в якому планується участь учнів. Тут немає жорстких стандартів.
fox11 Дата: Пн, 17.12.2018, 08:11 | Повідомлення № 52
Прописаний назавжди
Повідомлень: 333
Нагороди: 4
Рейтинг: 81
Цитата Bandalak ()
Але ми будемо користуватися виключно тим, що буде на олімпіаді
И то и другое MinGW?
Bandalak Дата: Пн, 17.12.2018, 21:05 | Повідомлення № 53
Лідер форуму
Повідомлень: 6192
Нагороди: 44
Рейтинг: 285
Торік був Codeblock з підключеним компілятором MinGW. Не знаю якої там версії був С++.
Apice Дата: Вт, 18.12.2018, 08:42 | Повідомлення № 54
Прописаний назавжди
Повідомлень: 244
Нагороди: 5
Рейтинг: 65
Цитата Bandalak ()
Торік був Codeblock з підключеним компілятором MinGW. Не знаю якої там версії був С++.
Щоб компілятор g++ (або MinGW) працював із новим стандартом вказівок слід просто позначити відповідну опцію у вікні налаштування компілятора (у CodeBlocks: Settings -> Compiler... )
так у Linux. У Windows, мабуть, аналогічно
Прикріплення: 4846016.png(107.5 Kb)
Bandalak Дата: Вт, 18.12.2018, 12:18 | Повідомлення № 55
Лідер форуму
Повідомлень: 6192
Нагороди: 44
Рейтинг: 285


Тут по замовчуванні жодна галочка не стоїть.
Я так розумію, що для нової версії потрібно відмітити С11, так?
А яка версія компілятора тут без галочок по замовчуванні?

-------------------------------------------------------------------------
Ще би знати яка версія використовується на перевіряючому сервері..... ?
Прикріплення: 8267188.jpg(92.2 Kb)
Apice Дата: Вт, 18.12.2018, 12:34 | Повідомлення № 56
Прописаний назавжди
Повідомлень: 244
Нагороди: 5
Рейтинг: 65
Цитата Bandalak ()
А яка версія компілятора тут без галочок по замовчуванні?
Мені здається, що 98, проте можу помилятися.
Цитата Bandalak ()
Ще би знати яка версія використовується на перевіряючому сервері..... ?
У нас (у Харківській області) тестуюча система дає можливість обрати мову, при цьому вказується версія стандарту. Мені здається, що у цьому році був 17. Разом з тим, якщо Ваш учень використовує стандарт 11, то 17 версія його "проковтне", а якщо навпаки, то видасть помилку компіляції. У мого сина колись таке було: обрав для перевірки версію C 98 і у заголовку циклу з параметром спробував ініціалізувати значення параметру - видало помилку компілятора. Потім, подумавши трошки, обрав версію C11 - задача зайшла.
swetikccc Дата: Вт, 18.12.2018, 13:22 | Повідомлення № 57
Ветеран спілкування
Повідомлень: 4158
Нагороди: 31
Рейтинг: 387
Цитата Bandalak ()
А яка версія компілятора тут без галочок по замовчуванні?
А перевірте, 11 точно піцдтримує
https://proglib.io/p/modern-cpp-features/
Пилипчук_О_П Дата: Вт, 18.12.2018, 15:30 | Повідомлення № 58
Ветеран спілкування
Повідомлень: 4308
Нагороди: 38
Рейтинг: 406
Цитата Bandalak ()
Ще би знати яка версія використовується на перевіряючому сервері..... ?

З цим питанням - до організаторів. Ця інформація має бути доступною майбутнім учасникам.
Bandalak Дата: Ср, 19.12.2018, 00:46 | Повідомлення № 59
Лідер форуму
Повідомлень: 6192
Нагороди: 44
Рейтинг: 285
Цитата Пилипчук_О_П ()
З цим питанням - до організаторів.

Надали тільки таку інфу:
Прикріплення: ___-III__.docx(38.6 Kb)
Apice Дата: Ср, 19.12.2018, 08:25 | Повідомлення № 60
Прописаний назавжди
Повідомлень: 244
Нагороди: 5
Рейтинг: 65
Цитата Bandalak ()
Надали тільки таку інфу:
Для перевірки робіт учасників будуть використані такі версії компіляторів: GCC 4.7.2, Java 1.7 ([u]http://www.oracle.com/technet....u] ), FPC 2.4, Python 3.4.3 (https://www.python.org/downloads/).

Щодо GCC 4.7.2 або пізніших - вони підтримують стандарт C++11 (https://www.gnu.org/software/gcc/gcc-4.7/changes.html)
Форум інформатиків » РОЗДІЛ VIІІ: ОБМІН ДОСВІДОМ (УРОКИ, ФАКУЛЬТАТИВИ, ПОЗАКЛАСНА РОБОТА) » 8.6 Факультатив з програмування » Мова С++ (поради, запитання....) (Все що стосується програмування на С++)
  • Сторінка 4 з 5
  • «
  • 1
  • 2
  • 3
  • 4
  • 5
  • »
Пошук:


© Форум інформатиків України, 2007-2019.